Fermer
ActualitésNavigateurs Web

Firefox pourrait bientôt bloquer les plugins par défaut

Les plugins sont un mal nécessaire de l’Internet. Ces derniers, souvent vulnérables, qui permettent de réaliser du streaming vidéo et audio sur les navigateurs Web, sont régulièrement exploitées par les pirates. Pour arrêter la propagation de logiciels malveillants, Mozilla se voit maintenant dans l’obligation de changer la façon dont Firefox gère les plugins.

Mozilla a annoncé que Firefox allait bientôt bloquer la plupart des plugins tiers par défaut. Cela signifie que les futures versions de Firefox vous demanderont votre autorisation afin d’afficher le contenu autorisé par le plugin. De plus, il est mentionné que les autorisations seront traitées par site.
Benjamin Smedberg, directeur de l’ingénierie chez Mozilla, indique que le changement est conçu pour fournir aux utilisateurs une “meilleure expérience Firefox”. Maintenant, quand un site essaye d’activer un plugin, les utilisateurs devront choisir d’activer ou non le système tiers.

Firefox pourrait bientôt bloquer les plugins par défaut

Rassurez-vous, il convient de noter que Firefox ne va pas bloquer tous les plugins tiers. La firme indique qu’elle ne va pas bloquer Adobe Flash par exemple, celui-ci étant “si fréquent sur le Web”. Mozilla note également que le blocage de Flash par défaut pourrait être une source de confusion pour de nombreux utilisateurs en raison du fait que de nombreux sites Web utilisent des instances Flash cachés dans une page Web.

Attendez, c’est un peu injuste, non ? Flash n’est pas tout aussi vulnérable que n’importe quel autre plugin, alors pourquoi aurait-il un traitement spécial ? Pour commencer, Flash est encore partout sur ​​le Web, et un blocage de facto ruinerait beaucoup de pages Web pour beaucoup de gens. Par ailleurs, Firefox bloque déjà les versions antérieures de Flash tout en rappelant aux utilisateurs de mettre à niveau vers la dernière version sécurisée.

Mozilla veut peut-être essayer de protéger les utilisateurs avec cette dernière initiative, mais ce n’est pas la seule raison du pourquoi elle bloque les plugins. La Fondation est connue comme étant un fervent partisan des technologies du Web comme HTML5, et a encouragé les développeurs à abandonner les plugins en faveur de celui-ci. Alors que HTML5 a certes fait de grands progrès au cours des dernières années, il ne peut pas égaler la performance d’un plugin comme Flash ou le Unity Web Player. Jusqu’à ce qu’il puisse, les plugins sont là pour rester…

Si vous voulez essayer le nouveau bloqueur de plugin pour vous-même, il vous suffit de tous simplement télécharger la dernière version de Firefox Aurora.

Mots-clé : FirefoxFlashjavaMozillaplugins
Yohann Poiron

L’auteur Yohann Poiron

J’ai fondé le BlogNT en 2010. Autodidacte en matière de développement de sites en PHP, j’ai toujours poussé ma curiosité sur les sujets et les actualités du Web. Je suis actuellement engagé en tant qu’architecte interopérabilité.